Hardware- und Software-Anforderungen

OTOBO kann als Webanwendung unter Linux und anderen Unix-Derivaten wie OpenBSD oder FreeBSD installiert werden. Das Ausführen von OTOBO unter Microsoft Windows wird nicht unterstützt.

Die Webanwendung nutzt eine relationale Datenbank als Backend. Um OTOBO ausführen zu können, benötigen Sie also mindestens einen Webserver und einen Datenbankserver. Diese können wahlweise beide auf einem Server oder auf unterschiedlichen Hosts installiert werden.

Alternativ kann OTOBO unter Docker ausgeführt werden. In diesem Fall sind Web- und Datenbankserver bereits im Setup enthalten. Die Bereitstellung mit Kubernetes wird derzeit gerade entwickelt.

The OTOBO web application requires Perl along with additional Perl modules from CPAN. The modules can be installed either with a Perl package manager or via the package manager of your operating system (rpm, yast, apt-get). There is a console command for checking the module dependencies:

otobo> /opt/otobo/bin/otobo.CheckModules.pl --inst

Falls Pakete fehlen, erhalten Sie einen Installationsbefehl für Ihr Betriebssystem, indem Sie das Skript mit der Option --list ausführen.

otobo> /opt/otobo/bin/otobo.CheckModules.pl --list | more

Die aufgeführten Befehle sollten dann mit Root-Berechtigungen ausgeführt werden.

In der Ausgabe des Modulprüfungsskripts werden die installierten Pakete und Versionsnummern angezeigt. Fehlende Module sind durch einen Kommentar gekennzeichnet.

Required packages:
  o Archive::Tar.....................ok (v2.32)
  o Archive::Zip.....................ok (v1.67)
  o Const::Fast......................ok (v0.014)
  o Date::Format.....................ok (v2.24)
  o DateTime.........................ok (v1.51)
    o DateTime::TimeZone.............ok (v2.38)
  o Convert::BinHex..................ok (v1.125)
  o DBI..............................ok (v1.643)
  o Digest::SHA......................ok (v6.02)
  o File::chmod......................ok (v0.42)
  o List::AllUtils...................ok (v0.15)
  o LWP::UserAgent...................ok (v6.26)
  o Moo..............................ok (v2.003006)
  o namespace::autoclean.............ok (v0.29)
  o Net::DNS.........................ok (v1.22)
  o Net::SMTP::SSL...................ok (v1.04)
  o Path::Class......................ok (v0.37)
  o Sub::Exporter....................ok (v0.987)
  o Template::Toolkit................ok (undef)
  o Template::Stash::XS..............ok (undef)
  o Text::CSV........................ok (v1.95)
  o Text::Trim.......................ok (v1.04)
  o Time::HiRes......................ok (v1.9760)
  o Try::Tiny........................ok (v0.30)
  o URI..............................ok (v1.71)
  o XML::LibXML......................ok (v2.0207)
  o YAML::XS.........................ok (v0.81)
  o Unicode::Collate.................ok (v1.27)
  o CGI::PSGI........................ok (v0.15)
  o DBIx::Connector..................ok (v0.56)
  o Path::Class......................ok (v0.37)
  o Plack............................ok (v1.0047)
  o Plack::Middleware::ForceEnv......ok (v0.02)
  o Plack::Middleware::Header........ok (v0.04)
  o Plack::Middleware::Refresh.......ok (undef)
  o Plack::Middleware::ReverseProxy..ok (v0.16)
  o Plack::Middleware::Rewrite.......ok (v2.101)
  o SOAP::Transport::HTTP::Plack.....ok (v0.03)

Recommended features for setups using apache:
  o ModPerl::Util....................ok (v2.000011)

Database support (installing one is required):
  o DBD::mysql.......................ok (v4.050)

Various features for additional functionality:
  o Encode::HanExtra.................ok (v0.23)
  o Net::LDAP........................ok (v0.66)
  o Crypt::Eksblowfish::Bcrypt.......ok (v0.009)
  o XML::LibXSLT.....................ok (v1.99)
  o XML::Parser......................ok (v2.46)

Features enabling communication with a mail-server:
  o Net::SMTP........................ok (v3.11)
  o Mail::IMAPClient.................ok (v3.42)
  o Authen::SASL.....................ok (v2.16)
  o Authen::NTLM.....................ok (v1.09)
  o IO::Socket::SSL..................ok (v2.067)

Optional features which can increase performance:
  o JSON::XS.........................ok (v4.02)
  o Text::CSV_XS.....................ok (v1.41)

Required packages if you want to use PSGI/Plack (experimental and advanced):
  o Gazelle..........................ok (v0.49)
  o Linux::Inotify2..................ok (v2.2)
  o Plack::App::File.................ok (undef)

Hardware-Anforderungen

Die Hardware-Anforderungen sind weitgehend davon abhängig, wie OTOBO genutzt wird. Mit OTOBO können wenige Tickets pro Monat oder mehrere Tickets pro Tag verarbeitet werden. Die Anforderungen an den Speicherplatz hängen ebenfalls von der Anzahl der Tickets und der Größe der Anlagen ab.

Mindestanforderungen für den Testbetrieb:

  • kleine CPU
  • 4 GB RAM
  • 10 GB Speicher

Mindestanforderungen für den Produktivbetrieb:

  • 3 GHz Xeon oder vergleichbare CPU
  • 8 GB RAM (16 GB empfohlen)
  • 40 GB Speicher

Bemerkung

Hardware-Anforderungen variieren stark und ergeben sich aus den individuellen Einsatzszenarien. Bitte lassen Sie sich von Ihrem OTOBO Consultant beraten.

Software-Anforderungen

Perl
  • Perl 5.24.0 oder höher
  • Alle Perl-Pakete, die vom Konsolebefehl /opt/otobo/bin/otobo.CheckModules.pl ausgegeben werden
Webserver
  • Apache HTTP Server Version 2.4
Datenbanken
  • MySQL 5.6 oder höher
  • MariaDB
  • PostgreSQL 9.2 oder höher
  • Oracle 10g oder höher
Optional
  • Elasticsearch 7.x (Schnellsuche mit Live-Preview)
  • Redis (schnelles Caching)
  • nginx oder jeder andere Webserver, der als Reverseproxy eingesetzt werden kann (SSL-Unterstützung und Lastverteilung)
Webbrowser
  • Apple Safari
  • Google Chrome
  • Microsoft Internet Explorer 11 (nutzbar, bietet aber nicht den vollen Funktionsumfang und alle GUI-Aspekte)
  • Microsoft Edge
  • Mozilla Firefox
  • Jeder andere moderne Webbrowser mit JavaScript-Unterstützung